Mollie Point of Sale minor outage
Incident Report for Jamezz
Resolved
This incident has been resolved
Posted Nov 16, 2023 - 20:46 CET
Monitoring
Mollie is experiencing minor outage on the payment terminals. They have found the issue and are actively monitoring if new issues occur
Posted Nov 16, 2023 - 14:18 CET