CM Payments disrupted
Incident Report for Jamezz
Resolved
The incident has been resolved and CM payments is back up.
Posted Aug 24, 2023 - 15:49 CEST
Investigating
CM Payments is currently experiencing disruption on their payment platform. Customers using CM payments as a payment provider will not be able to process payed orders. CM payments is investigating the issue.
Posted Aug 24, 2023 - 14:37 CEST